[루비온레일즈] Add 'gem sqlite3' to your Gemfile 에러를 뿜을 때

Web/RubyOnRails 2013.12.22 01:20

 

 

 

Ruby 명령창에 rails s를 치고

 

웹브라우저에 http://localhost:3000을 입력하는 순간.

 

Add 'gem sqlite3' to your Gemfile 에러를 마주하면 적지 않게 당황스럽다.

정확히는 붉은 글자

Specified 'sqlite3' for database adapter, but the gem is not loaded. Add `gem 'sqlite3'` to your Gemfile.

다.

 

이것은 sqlite3를 틀림없이 설치해 놓았더라도,

개발환경이 윈도우 64비트 운영체제인 경우에 발생할 수 있다.

 

당황하지말고 프로젝트 트리에서 Gemfile.lock 파일을 찾아간 다음,

 

sqlite3 (1.3.8-x86-mingw32) 이라고 되어있는 부분을 아래와 같이 고쳐주면 해결된다.

 

sqlite3 (1.3.8-x64-mingw32)


설정

트랙백

댓글