RubyMine이 Cannot Switch SDK 에러를 뱉어낼 때

Web/RubyOnRails 2014.08.19 15:42


github에서 어떤 루비온레일즈 소스를 받아서 실행할 때, Cannot Switch SDK 에러를 만날 경우가 있다.


dvm use [루비버전]을 몇 번이나 실행해보고 확인해도 문제가 해결되지 않는다면,

.ruby-version 파일을 찾아 열어보라!


RubyMine을 위한 target version 설정은 아래와 같아야 한다.


ruby-[루비 버전]


예)

ruby-2.1.1


보통 2.1.1과 같이 버전만 적혀있는 경우가 있는데,

IntelliJ에서는 문제가 없으나 RubyMine에서 문제가 튀어나온다.

 
이것은 rails composer 템플릿이 해당 파일을 자동생성하면서 만드는 문제인 것 같다.


ruby-[루비 버전] 하면,


양쪽 IDE에서 두루두루 평안하리라.

저작자 표시 비영리 동일 조건 변경 허락
신고
크리에이티브 커먼즈 라이선스
Creative Commons License

설정

트랙백

댓글